AutoDesk Revit 2017 for Architecture

524 lessons : 48:18:29 (hh:mm:ss)

Description:

CADLearning for Autodesk Revit 2017 for Architecture covers the use of Revit 2017 as an architectural and
construction modeling tool. Revit is the most popular architectural design tool from Autodesk, with capabilities for
modeling, analysis, documentation, and collaboration. Beginner, Intermediate, and Advanced users will learn the
core and architectural functions of Revit as it works within the world of Building Information Modeling, or BIM.

e Getting Started
* Opening a Project File
» |dentifying the User Interface Components
» Managing User Interface Components
» Understanding the Ribbon
» Customizing the User Interface
» Understanding the Quick Access Toolbar
» Understanding the Options Bar
» Understanding the Application Menu
»= Using the Revit App Store
» Understanding the Project Browser
» Understanding the Properties Palette
» Understanding the Type Selector
» Understanding the Status Bar
» Understanding the Drawing Area
» Understanding the View Controls
» Understanding the Navigation Bar
» Understanding the ViewCube
» Understanding the Steering Wheels
» Understanding the Options Dialog
» Managing File and Template Locations
= Managing the Places List
= Setting the Default Family Library Location
» Starting a New Project from Recent Files
» Starting a New Project from the Application Menu
= Controlling Project Units
» Controlling Snaps Settings
* Using the Mouse
» Using the Keyboard
» Customizing Keyboard Shortcuts
* Managing Windows
»= Understanding Macros
» Saving and Closing Files
» Closing the Application
¢ Revit Fundamentals
» Understanding BIM
» Understanding the Difference Between BIM and CAD



» Understanding Revit Concepts
» Understanding Bidirectional Associativity
» Recognizing Parametric Relationships
» Understanding Families
» Placing Model Elements
= Sketching Model Elements
» Placing View-Specific Elements
=  Working with Datum Elements
» Placing Elements from the Project Browser
* Loading Families and Using Type Catalogs
* Finding Families Using Autodesk Seek
» Editing Families Within a Project
e Basic Modify and Reporting Tools
» Selecting Objects
*» Modifying Selection Settings
» Saving Selection Sets
» Copying and Moving Objects
* Rotating Objects
= Creating Linear Arrays
»= Creating Radial Arrays
= Scaling Objects
= Mirroring Objects
» Using the Clipboard for Copy and Paste
= Splitting Objects
» Creating Elements Consistently with Match Type Properties and Create Similar
= Aligning Objects
= Trimming and Extending Objects
= Offsetting Objects
* Pinning Objects in Place
» Deleting Objects
= Cutting and Joining Geometry
» Splitting the Face of an Element
= Applying Materials as Paint
» Measuring versus Dimensioning Objects
» Understanding Element IDs
» Understanding and Reviewing Warning Messages
o Sketch Tools
» Creating Tangency Locks
¢ Modeling Essentials
»= (Creating and Modifying Levels
» Creating and Modifying Grids
» (Creating and Modifying Multi-Segment Grids
» Controlling the Display of Levels and Grids
» Limiting Visibility of Datum Using Scope Boxes
» Setting and Showing the Active Work Plane
» Creating Reference Planes in a Project
* Modeling Accurately with Length and Angle Snap Increments
=  Working with Object Snaps



Using Visualization Aids When Working in 3D Views

e Core and Shell

Creating Exterior Building Walls

Creating Building Core Walls

Creating Doors

Creating Windows

Modifying Door and Window Properties
Creating Curtain Walls

Placing Doors in Curtain Walls

Creating Curtain Wall Grids and Mullions
Understanding Compound Structures
Creating Floors

Understanding Floor Instance Properties
Understanding Floor Type Properties
Creating Sloped Floors by Sketching
Creating Sloped Floors by Shape Editing
Creating Floor Openings

Creating Shaft Openings

Creating a Roof by Footprint

Creating a Roof by Extrusion

Joining and Unjoining Roofs
Understanding Roof Instance Properties
Understanding Roof Type Properties
Working with Sloped Glazing Roofs
Creating Sloped Roofs by Sketching
Creating Sloped Roofs by Shape Editing
Creating Conical Roofs

Managing Complex Roof Conditions Using Align Eaves
Creating Roof Soffits

Creating Fascias

Creating Dormer Openings

Creating Roof Openings

Modifying Roof and Wall Joins and Controlling Roof Visibility
Creating Gutters and Downspouts

An In-Depth Look

Creating Walls

Understanding Wall System Families and Types
Understanding Wall Drawing Aids
Creating Walls by Picking Lines
Understanding Wall Instance Properties
Understanding Wall Type Properties
Changing the Wall Type as Your Design Evolves
Understanding Curtain Wall Types
Selecting Curtain Wall Components
Working with Curtain Wall Grids

Creating a Curved Curtain Wall
Embedding a Curtain Wall in Another Wall
Working with Curtain Wall Panels



Understanding Mullion Families

Modifying Mullion Join Conditions

Working with Corner Mullions

Modifying Curtain Wall Corner Conditions
Customizing Curtain Wall Mullions

Creating a Stacked Wall

Creating Walls Using the Modify Tools

Modifying Wall Profiles

Creating Wall Openings

Introducing Wall Layer Functions

Overriding Host Layer Display

Understanding Wall Join Cleanups

Understanding Wall Layer Wrapping

Customizing Vertical Wall Structure by Splitting Regions
Customizing Vertical Wall Structure by Adding Sweeps
Customizing Vertical Wall Structure by Adding Reveals
Customizing the Base and Top Extension of Walls
Creating Embedded Walls

Creating In-Place Wall Sweeps

Creating In-Place Reveals

Creating Joined Walls for Complex Assemblies

e Stairs and Railings

Creating Stairs

Creating Stair Landings

Creating Support Components

Creating Stair Components by Sketching
Modifying Stair Components

Tagging Stairs

Customizing Stair Documentation
Understanding Stair Properties

Creating Spiral Stairs

Creating Multi-Story Stairs and Shafts
Creating Ramps

Placing Railings on a Host

Creating Railings by Sketch

Modifying Railings

Working in the Railing Type Properties Dialog
Understanding Railing Properties
Customizing Railing Properties

e Building Interiors

Creating Interior Partitions

Creating Interior Storefront Glazing

Placing Rooms

Placing Rooms Automatically

Creating Room Separation Lines

Managing Area and Volume Computation Settings
Placing Components

Placing Hosted Components



» Creating Architectural Columns

» Creating Ceilings

» Placing Building Components in Ceilings

= C(Creating Area Plans

»= Creating Area Boundary Lines

» Creating Areas and Area Schedules

» (Creating and Managing Color Schemes
e Design Analysis

= Understanding Energy Settings

» Understanding the Advanced Energy Settings

= Working with Energy Analytical Models

» Performing Energy Simulations

» Reviewing Energy Simulation Results
e SiteTools

» Creating a Toposurface Using Points

» Creating a Toposurface from CAD

» Creating a Toposurface from a Points File

= Managing Site Settings

= Controlling the Display of Contour Lines

= Splitting and Merging Surfaces

» Creating Toposurface Subregions

» C(Creating a Building Pad

» Creating a Graded Region

» Creating Site and Parking Components

= Creating Property Lines

» Adding Property Line Tags and Contour Labels
¢ Parameters

» Understanding Parameters

= Creating Project Parameters

» Modifying Project Parameters

» Understanding Shared Parameter Files

» Creating a Shared Parameters File

» Creating Shared Parameters

» Using Shared Parameters in Projects

» Adding Shared Parameters to Tags

» Understanding Global Parameters

» Creating Global Parameters

» Associating Global Parameters

» Labeling Dimensions with Global Parameters

»= Using Global Parameters as Reporting Parameters

»=  Working with Uniformat Assembly Code Information

= Working with OmniClass Number Information
e Schedules

» Understanding Schedules

= Working with Schedules

» (Creating a Schedule and Specifying Fields

» Scheduling Fields from Rooms and Project Information

» Adding Calculated Value Formulas to Schedules



» Adding Calculated Value Percentages to Schedules
» Combining Parameters in Schedules
» Filtering Schedules
= Sorting and Grouping Schedules
» Hiding and Unhiding Schedule Columns
»= Grouping Schedule Headers
* Formatting Schedule Headers and Data
» Calculating and Displaying Totals in Schedules
»= Calculating Minimum and Maximum Values in Schedules
» Adding Conditional Formatting to Schedules
» Adjusting the Schedule Title Section
» Adding Additional Information to Schedule Titles
* Modifying the Schedule Appearance
» Using Key Schedules
» Understanding Schedule View Templates
» Creating a View Template for Schedule Appearance
» Creating Schedule View Templates
» Placing Schedules on a Sheet
= Working with Room, Space and Area Schedules
= Working with Material Takeoff Schedules
* Importing and Exporting Schedule Views
» (Creating and Managing View Lists
¢ Annotation
» Understanding Tags
» Controlling Default Tags
» Tagging Elements on Placement
» Tagging All Elements Not Tagged
» Tagging Elements Individually
= Pinning Tags
» Placing Room and Area Tags
= Working with Material Tags
» Creating Calculated Values in Tags
* Modifying the Appearance of Tags
» Understanding Text
* Placing Text Notes
» Placing Text Notes with a Leader
= Creating Text Types
» Changing the Height of Text
»= Controlling Text Font
= Creating Lists in Text Notes
» Editing Text Notes
» Adjusting Text Leaders
» Using Keyboard Controls to Add Symbols to Text
» Checking Spelling in a View
* Finding and Replacing Text
*»  Working with Legends
* Managing Arrowheads



¢ Dimensions and Constraints

Using Temporary Dimensions

Modifying Temporary Dimension Settings
Working with Permanent Dimensions
Modifying Dimensions

Modifying Dimension Graphics

Modifying Dimension Text Appearance
Creating and Modifying Dimension Styles
Modifying Dimension Text

Locking Dimensions

Controlling Dimensions Using Equality Constraints
Creating Constraints

Controlling Dimension Units
Dimensioning Entire Walls

Working with Spot Elevations

Working with Spot Coordinates

Working with Spot Slopes

o Drafting and Detailing

Loading and Placing Detail Components
Placing Repeating Details

Creating a Repeating Detail

Creating Detail Lines

Specifying Draw Order

Showing Hidden Lines in Detail Views
Modifying the Cut Profile of Model Elements
Overriding Linework in a View

Creating Filled Regions

Creating Masking Regions

Creating Batt Insulation

Placing Annotations in Detail Views
Leveraging Detail Groups

Saving Views to a File

Inserting Views and 2D Elements from a File
Creating Model Text and Model Lines

e View Graphics

Working with Visual Styles

Understanding Scale and Detail Level
Understanding Plan View Range

Adjusting the View Range

Adding an Underlay

Understanding View Discipline

Understanding View Templates

Creating View Templates

Applying and Assigning View Templates
Creating View Types

Understanding Object Styles

Understanding Visibility and Graphic Overrides
Overriding the Visibility and Graphics of Elements and Categories



» Overriding Visibility and Graphics with Filters
» Using Temporary Hide or Isolate and Viewing Hidden Elements
= Using Temporary View Properties
» Understanding Crop Regions
» Creating a Non-Rectangular Crop Region
» Understanding Annotation Crop Regions
» Configuring System Family Coarse Scale Fill Patterns
* Increasing Performance with Graphics Mode Options
= Using Anti-Aliasing
» Understanding Saved View Conditions
¢ Views and Sheets
» Creating Plan Views and Reflected Ceiling Plan Views
» C(Creating a Plan Region
» (Creating Building Elevation Views
» Creating Interior Elevation Views
» Creating Framing Elevation Views
» Changing the Elevation Symbol
= Creating Section Views
= Segmenting Section and Elevation Views
»= (Creating Callout Views
= Sketching a Callout View
» Creating Drafting Views
» Creating a Reference View
* Duplicating Views
» Creating Matchlines and View References
» Creating Additional View References
» (Creating and Managing View Lists
» (Creating Sheets
» Placing Views onto Sheets
= Working with Viewports on Sheets
= Aligning Views on Sheets with a Guide Grid
» Using a Sheet List and Placeholder Sheets
» Creating Custom Titleblocks
» Creating a Key Plan
*» Managing Sheet Issues and Revisions
» Controlling Which Revisions Appear on Sheets
e Printing
* Printing and Managing Print Settings
»= Printing to PDF
¢ Managing Projects
= Managing Project Information
» Understanding How the Location and Site Relate
» Specifying a Project Location
» Understanding Coordinate Systems
» Understanding the Clipped and Unclipped States of Points
»  Working with the Project Coordinate System
»  Working with the Shared Coordinate System
» Relocating a Project



Rotating True North

Rotating Project North

Mirroring a Project

Managing Settings

Understanding Materials

Working in the Material Browser

Managing Materials

Creating New Materials

Creating a Material Library

Loading and Unloading Material Libraries
Controlling Material Properties

Controlling Material Graphics and Appearance
Controlling Material Physical and Thermal Assets
Editing Material Assets

Understanding Model and Drafting Patterns
Managing Fill Patterns

Creating Model Fill Patterns

Creating Drafting Fill Patterns

Working with PAT Files to Create Fill Patterns
Managing Line Styles

Managing Line Weights

Managing Line Patterns

e Worksharing

Introducing Worksharing Concepts

Understanding Worksharing Terminology

Enabling Worksharing in a Project File

Creating the Central Model

Creating a Local Copy of a Central Model

Creating Worksets

Understanding Workset Visibility

Understanding How Central and Local Models Communicate
Transferring Changes Between Local Models and the Central Model
Using Editing Requests

Understanding the Active Workset

Working with Worksharing Display Modes

Specifying Open Worksets

Managing Worksets in Linked Revit Files

Unloading Links in Workshared Projects

Working Offline with a Workshared Project

Editing a Workshared Project at Risk

Viewing the Workshared Project History

Rolling Back Workshared Projects

Opening a Workshared Project Independent of the Central Model

e Coordination

Linking Revit Models

Repositioning Linked Revit Models

Controlling the Display of Elements in a Linked Model
Scheduling Elements from a Linked Model



» Tagging Elements in a Linked Model

* Monitoring and Coordinating Changes Within a Single Project
» Using Copy and Monitor in a Single Project

» Using Copy and Monitor with Linked Projects

» Performing a Coordination Review with Linked Models

» Checking for Interferences

* Introducing Groups
» Creating a Model Group
» Placing Groups
» Creating and Managing Model Groups and Attached Detail Groups
= Attaching Annotation Detail Groups
» Creating Detail Groups
» Editing Groups
= Making Parameters Vary Between Groups
» Excluding Elements from Groups
= Converting Groups to Links
= Converting Links to Groups
»= Saving and Loading Groups
e Phases
* Introducing Phases
» Understanding Phases
* Managing Phases
» Understanding Phase Filters and Graphic Overrides
» Assigning Phases and Phase Filters to a View
» Understanding the Impact of Phases on Documentation
= Demolishing Elements
» Establishing Phases in Project Templates
e Design Options
* Introducing Design Options
=  Working with Design Options and Option Sets
» Editing Design Options
* Duplicating and Deleting Design Options
= Creating Design Option Views
» Understanding the Impact of Design Options on Documentation
*» Promoting and Accepting Design Options
e Advanced Modeling
* Introducing the In-Place Modeling Tools
»= Creating In-Place Family Objects Using Solid Extruded Forms
»= Creating In-Place Family Objects Using Solid Blended Forms
»= Creating In-Place Family Objects Using Solid Revolved Forms
»= Creating In-Place Family Objects Using Solid Swept Forms
» Enhancing In-Place Families
» Understanding Adaptive Components
» Using Adaptive Components to Create Building Elements
¢ Family Creation
» Understanding Loadable Families
* Introducing Family Creation



Understanding the Family Editor

Working with Tag Families

Creating a Custom Annotation Tag

Creating a Custom View Tag

Creating a Custom View Title

Working with Component Families
Introducing Form Creation

Creating Extrusions

Creating Blends

Creating Revolves

Creating Sweeps

Creating Swept Blends

Creating Void Forms

Creating Reference Planes and Reference Lines
Controlling the Display of Reference Planes
Creating Dimension and Parameter Constraints
Creating Family Geometry

Understanding Family Geometry Display Settings
Using Family Visibility Preview

Working with Hosted Families

Creating Hosted Families

Creating Family Types

Working with Families in a Project

Creating Family Parameters

Adding Formulas to Family Parameters
Using Shared Parameters in Families
Organizing Family Parameters
Understanding Reporting Parameters
Linking Parameters in Component Families
Using Family Parameters to Control Visibility
Creating Symbolic and Model Lines

Creating Controls

Creating Masking Regions

Managing Nested Families

Creating a Type Catalog

Exporting Family Types

Importing Family Types

e Presentation Views

Creating 3D Views

Understanding 3D View Properties

Specifying the Background for 3D Views
Rotating 3D Views

Using Section Boxes in 3D Views

Using Selection Boxes

Creating Perspective 3D Views

Working in Perspective Views

Modifying the Perspective Field of View
Storing a 3D View Home and Front Orientation



Orienting 3D Views to Other Views

Locking 3D Views for Annotation

Creating Exploded Views with Displaced Elements
Using Sketchy Lines

Creating Decals

Managing Decal Types

Managing Photographic Exposure

Managing Shadows

Utilizing Depth Cueing

¢ Interoperability

Importing and Managing Image Files

Linking and Importing CAD Files

Managing Linked CAD Files

Controlling the Coordinates of Linked CAD Files
Managing Imported CAD Files

Controlling Line Weights in Imported CAD Files
Using CAD Files to Create Building Model Objects
Working with Autodesk Exchange Files

Linking Point Clouds

Working with Point Clouds

Controlling the Visibility of Point Clouds
Controlling the Color Mode of Point Clouds
Opening IFC Files

Linking IFC Files

Working with IFC Files

Specifying CAD Export Setup Options

Exporting to 2D CAD Formats

Exporting to 3D CAD

Exporting Views to Image Files

Exporting Rooms or Spaces to gbXML
Exporting the Energy Analytical Model to gbXML
Exporting to 3ds Max

Exporting Room and Area Reports

Controlling IFC Export Classes

Specifying IFC Export Setup Options

Exporting to IFC

Exporting to Civil 3D

Exporting to ODBC



